– Ken忘録 –

SC-01B の Google Maps を Wi-Fi のみで使用する場合の注意点

Posted in SC-01B by cuda on 2010年3月8日

f:id:cuda:20100305124942j:image:w250:right■ モバイルルーター( MiFi )のみで使うならSIMを抜け!■

 SC-01Bを購入してから、この端末では初めてGoogleMapsを使おうとしたところ、起動後、右のようなエラーが出て、現在地の補足が出来ませんでした。私のスマフォ使用環境はちょっと変で、全ての端末をMiFi(WC3G)のみで賄っています。ですので、SIMは抜いてしまっています。しかし、BB9700だけはSIMを挿していないとWi-Fiではメールが使用出来ないので、SIMを挿して3Gを切って使っています。そんな流れでなぜかSC-01BもSIMを抜かずに3Gを切って使用していました。なぜ、エラーが出るのか判らず、いろいろと試してみました。

  1. A-GPS : 有効 / GoogleMaps : GPSを使用する(チェック入れた状態) → エラー
  2. A-GPS : 有効 / GoogleMaps : GPSを使用しない(チェック外した状態) → エラー
  3. A-GPS : 無効 / GoogleMaps : GPSを使用する(チェック入れた状態) → エラー
  4. A-GPS : 無効 / GoogleMaps : GPSを使用しない(チェック外した状態) → 一応現在地付近を捕捉

4.の場合でも正確では無く、同じ場所の表示なので、MiFiに挿しているSIMの基地局で測位しているのでしょうか?GPS衛星数や移動しても現在地が●から矢印にならないので、変だなと思っていたら、mobachikiさんのところのキャプチャを見て、“ あっ!”っと思って「 GPSToggle 」を試してみる事にしたのですが、これもエラーでONにならず。どうも端末がA-GPSのみならず、GPSすらキャッチしていないというようです。そこで、TreoProと同じ状態にしてみようとSIMを抜いて3GをONにして、GPSToggleを起動させると「 位置情報サービスが開始されました 」とメッセージが出て、ONになりGPSを捕捉しました。続いて、GoogleMapsを起動してみると、こちらもちゃんと起動して現在地を捕捉し、GPS衛星数、矢印も出ました。

まだ良く理解していないのですが、どうもFOMA-SIMを挿していると3GをOFFにしていても、A-GPSを優先してしまうようですが、設定でA-GPSを無効にすると、GPSも無効になってしまうみたい(?)です。それで、上のようなテストをしても無駄だったわけですね。まあ、こんな変な使い方をしていなければ、右往左往することも無かったのですが。。。やれやれ、です。Twitter界隈で嘆いた為に、ご迷惑をお掛けしてしまい、すみませんでした。

広告

コメントを残す

以下に詳細を記入するか、アイコンをクリックしてログインしてください。

WordPress.com ロゴ

WordPress.com アカウントを使ってコメントしています。 ログアウト / 変更 )

Twitter 画像

Twitter アカウントを使ってコメントしています。 ログアウト / 変更 )

Facebook の写真

Facebook アカウントを使ってコメントしています。 ログアウト / 変更 )

Google+ フォト

Google+ アカウントを使ってコメントしています。 ログアウト / 変更 )

%s と連携中

%d人のブロガーが「いいね」をつけました。